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Learning objectives

Configure QGIS projects for mobile field data collection.

Set up attribute forms with proper field types and constraints.
Deploy projects to QField using both cloud and offline methods.
Collect spatial data with photos and GPS coordinates in the field.

Synchronize field-collected data back to QGIS desktop.



What is QField?

Open-source mobile application for Android and i0S
Enables editing QGIS projects on mobile devices
Takes QGIS projects into the field for effective data collection

Maintains QGIS styling and edit widgete

for QGIS

(opengisch n.d.)
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QField workflow

1. Configure QGIS project (desktop)

2. Set up data layers and attributes

3. Deploy to QField

4. Collect data in the field

5. Synchronise back to QGIS
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Configuring the QGIS project

Create the project

e Folder structure:
o Project Folder
m Your QGIS project
m “ExportQField”
m ‘ImportQField”

e Save project without spaces in filename
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Configuring the QGIS project

In QGIS: Basemap

e Under the browser
(top left) you will
find the dropdown
XYZ Tiles

e Use the
OpenStreetMap
basemap

SCP Dodk Brosaser Linyws.
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Configuring the QGIS project @

Area of Interest (AOI)

e QGIS plugin: OSM Place Search
o Allows you to browse through the different place features available in
the OpenStreetMap data

e Under Plugins in the Menu toolbar, click Manage and Install Plugins

e In the search bar, type OSM Place Search and install the plugin

e A new window should appear in the side panel where you can enter your
AOl
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Creating the GeoPackage

What is a GeoPackage?

e A file-based database where you can store multiple layers, including
points, lines, polygons, and raster data

e Datasets are saved in one file, instead of multiple (shapefiles)
e Ends in .gpkg
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Creating the GeoPackage

(3} New GeoPackage Layer

e Select Layer > Create Layer > New ersc: 4226 - Gs o -JA®

Geopackage Layer: o

o For Database, click on (...) and R———— '
select your project folder and give a
suitable name .

o Choose a Table name

o For Geometry type, select points

o Select the desired Coordinate
Reference System (CRS) by b Advanced optons
clicking on the Globe icon \ e
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Creating the GeoPackage

Create a GeoPackage

e Under New Field add the following attribute columns:
o lulc_class: Value Map widget with predefined options (Text)
o Date: Auto-populated with now(), non-editable (Date and time)
o Photo: Attachment widget with relative paths and document viewer
(Text)
o Latitude/Longitude: Auto-populated ($x, $y), non-editable (Decimal)
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Create a GeOPaCkage (2 New GeoPackage Layer X
Database

)W\Insitu_data_collection\lulc_samples.gpkg €3

Table name lulc_samples

e Under New Field add the following attribute Geometry ype . Pont -
columns: rr—
o lulc_class: Value Map widget with .
predefined options (Text) o }
o Date: Auto-populated with now(), non-
editable (Date and time) F‘:‘::“t -
o Photo: Attachment widget with relative D S
paths and document viewer (Text) rhote e 5
o Latitude/Longitude: Auto-populated » Advanced Options .
($x, $y), non-editable (Decimal) ok || concel || nip
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Create a GeOPaCkage (2 New GeoPackage Layer X
Database

)W\Insitu_data_collection\lulc_samples.gpkg €3

Table name lulc_samples

e Under New Field add the following attribute Geometry ype . Pont -
columns: rr—
o lulc_class: Value Map widget with .
predefined options (Text) o }
o Date: Auto-populated with now(), non-
editable (Date and time) F‘:‘::“t -
o Photo: Attachment widget with relative D S
paths and document viewer (Text) rhote e 5
o Latitude/Longitude: Auto-populated » Advanced Options .
($x, $y), non-editable (Decimal) ok || concel || nip
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Attribute configuration @

It I e p rO p e rtl e S (Q Layer Properties — lulc_samples — Attributes Form X
A Drag and Drop Designer v @ Show Form on Add Feature (global settings) ~

1. Go the sample layer: Layer Bowe o e (e i
Properties > Attribute Form - —
2. Select Drag and Drop Designer from
the dropdown e
o Do not need to edit the fid field. e i —
QGIS creates this for every e
GeoPackage by default T
3. Remove the fid field from the visible
fields by pressing the -
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Attribute configuration @

Q Layer Properties — lulc_samples — Attributes Form X
Q Drag and Drop Designer + @ | Show Form on Add Feature (global settings) =
L U L C CI a S S Tl Available Widgets Form Layout & ~ Widget Display
—_ -
ﬁdc:z: fid rla; =] /| Show label
abe |ulc_class Photo 13 Override Label Color
Date :*"‘“U‘fﬂe »  Override Label Font
abe Photo ongtitude
1.2 Latitude
1.2 Longtitude
g v General
e Select lulc class: o
—_ #ll - Other Widgets = =
. QML Widget Comment
a Change the Wldget type from HTML Widget v/ Edtable | | Reuse lastentered value | | Label on top
.
* Widget Type
.
Text edit to Value Map a
Combo box with predefined items. Value is stored in the attribute,
. . @ description is shown in the combo box.
b. Enter the Value and Description = et e ] s o o
' Value Description
f | | | ¢/ 1 Vegetation Vegetation
Or you r u C C asses ° 2 Built-up Built-up
3 Water Water
c. Check the Not null button under E
. l‘ Add "NULL" value Remove Selected
the Constraint %
x = v Not null Enforce not null constraint
d [] CI ICk Apply r‘-,, Unique Enforce unique constraint
4] Expression Class is required o - £
Expression description
O Fnfrrra aynrecsinn constraint
Style ~ OK Cancel Apply Help
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Attribute configuration

o Select date:
a. Make sure it has the Date/Time format under the Widget Type
b. Under General, uncheck Editable
c. Under Defaults, in the Default value type, use now()
d. Click Apply
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Attribute configuration @

Photo i il |
A Drag and Drop Designer v @ Show Form on Add Feature (global settings) ~
ZHl Available Widgets Form Layout & =

e Select photo: ; e D

a. In the Widget Type section, select § M ,,,e
Attachment o —

b. Check Relative paths and select T e
Relative to Project Path e —

c. Check the ‘Use a hyperlink for ‘i 5
document path” box .

d. Select Image for the Type ”""‘“ _

e. Set Width and Height to 400px and o 3 T S
300px ‘o :

f. Click Apply
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Attribute configuration

Latitude and Longitude

e Edit latitude and longitude:
a. Under General, uncheck Editable.
b. In the Default value bar, type in $x for latitude and $y for longitude
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QField synchronisation methods

Two methods:

QField cloud
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QField offline
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QField synchronisation methods @

Cloud method Offline method

Automatic synchronisation Functions almost completely without

Wi-Fi
Multiple users can work on the same | Requires multiple manual steps (eg.
project USB transfer)
Easier setup More complex

Best for: most cases, teams, projects |Best for: extremely remote studies,
with many changes sensitive data
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QField cloud @

In QGIS: QField Sync Plugin

. . Q. qfield «
1. Direct to Plugins > Manage and R GFicld Sync :
# TeamArea Creator Sync your projects to QField M|

Install Plugins > All
2. Search for QFieldSync and install it
3. In QGIS a new toolbar should

This plugin facilitates packaging QGIS projects for QField.
It analyses the current project and suggests (and performs) actions

a
eeeeeeeeeeeeeeeeeeeeeeeeeee g on QField.

appear .
4. Start QField Sync
5. Login to QFieldCloud with your
username and password. If you have _—

Close Help

no username you can directly
register following the link
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QField cloud

- . (2 QFieldCloud Projects Overview
In QGIS: QField Sync Plugin |
Greetings daco.

6. Click on Plugins > QFieldSync > L& o test daco
QfieldCloud Projects Overview

7. In the QFieldCloud Projects Overview
window, click on the Create new Project

e,

Close Help
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(2 QFieldCloud Projects Overview

QField cloud

In QGIS: QField Sync Plugin e

6. Click on Plugins > QFieldSync >
QfieldCloud Projects Overview

7. Click on the Create new Project =]

8. Choose the recommended option
and click Next

9. You can enter a description and
click on Create and QFieldSync will
package your project for the cloud
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Close

- Owner

Q

Greetings daco.

Project Details

Name Insitu_sampling

Land Use Land Cover training point data collection

Descriptios
Owner daco C
Local Project Settings
Local Directory C:\Users\Daco\QField\coud\insitu_sampling ... |*
-
Clos Help
22



QField cloud

In QField: Synchronise in the app

1. On your mobile device open QField Application a

2. Click on QFieldCloud Projects and sign in with the @
same credentials as before

3. Your project should already be available

4. Click on it and download the project

peo
o
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QField cloud

In QField: Synchronise in the app '

1. On your mobile device open QField Application o

2. Click on QFieldCloud Projects and sign in with the @
same credentials as before

3. Your project should already be available

4. Click on it and download the project

28

Now you can do field work!
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QField cloud

In QField: Synchronise back

&«

Greetings daco.

There is/are 4 local change(s)

& Synchronize

Synchronize the whole project with all modified features
and download the freshly updated project with all the
applied changes from QFieldCloud
Save internet bandwidth by only pushing the local features
and pictures to the ud, without updating the whole
project
Revert all modified features in the local layers. You cannot
estore those change

Open the Side Dashboard: ¢« m & , G

e Click on the blue cloud, the number i ol
iIndicates how many changes you have
made) \~ Revert local changes

e Choose to push the changes if you are
happy with your field work

1l (@) <
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QField offline

In QGIS: Prepare your project

Create an offline copy of your QGIS project as a new file by adding
“ offline.qgs” into a new folder
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QField offline @

In QGIS: Layer packaging

e Each layer needs a "Layer Action" to define how QFieldSync handles it

Available Action Types:

e Copy: Creates static copy, no change tracking (for reference data)

e Keep existing (copy if missing): Avoids re-packaging, best for frequent
syncs

e Offline editing: Full tracking with changelog, enables synchronisation (for
the field)

e Directly access data source: Real-time access (requires internet)

¢ Remove: Excludes layer from mobile project
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QField offline @

In QGIS: Layer packaging

1. Add the Google Satellite basemap oo (HBTiis)

'@ Generate XZ tiles (MB

» -
Parameters Log Generate XYZ tiles

-1.714049376,-1.661247791,6.724090030,6.757359995 [EPSG:4326] Bg|~|] | This algorithm generates raster
XYZ tiles of map canvas content.

Minimum zool m

2. Zoom into your area of interest usingOSM
Place Search

3. Toolbox > Raster tools > Generate XYZ tiles

4. Click Extent, select Draw on Map Canvas and o
draw AOI —

5. Complete the dialog box as shown >

. Save the file to the offline project folder created

7. Remove the Google Satellite basemap and add

the saved MBTiles to the project
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QField offline

In QGIS: Package for QField

e Go to Plugins > QFieldSync
> Preference

e Set the Default packaging
import and export directory to
the Import and Export
Folders created on your local
drive

+" Rendering =

= Vector
= Raster
B8 Canvas & Legend
B Map Tools
m Digitizing
% 3D
A Colors
Fonts
] Layouts
Variables

&8 Authentication

== Network
"= GPS
*= GPSBabel
Locator
Acceleration
IDE
B Code Editor
¢ Python Console
) QField
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QFieldCloud Settings
QFfeldCioud allows your team to focus on what'’s Important, making sure you effidently get quality field data.
Thanks to its integration with QFfeld, you and your team will be able fo start surveying and digitising data
colfahorativaly in no time.
Default cloud directory |C:\Users\Daco\QField\doud a ..

/| Stay signed in

Packaging Settings

QFfeld continues to give users full control by allowing profects to be packaged and synchronized via USE cable as
well as through retworks,

Default packaging import directory D:\SKROW\2025\gfield\Import a || ..

Default packaging export directory  D:\SKROW\2025\gfield\Export a | .
v Show packaging actions in the toolbar

OK Cancel Help
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QField offline @

In QGIS: Package for QField

e Click on the MBTiles in your layers >

Packaged Project Title

Properties > QField int. sl (ko

e Change the Cable packing action t0 “KEEp " s o o e ssns @
existent (Copy if missing)” e

e Repeat this change for the lulc_samples
layer and any additional layer you may -
have roress

e On the Toolbar, click on the Package for
QField icon and confirm the packaged -
project directory Rcortrs et rfc

e Click Create to complete

EOCap4Africa — In-situ sampling in QField 30




QField offline @

In QField: Manually synchronise

e Copy the packaged folder into the gfield folder on your mobile device via
USB, Mail, etc.

Open QField App on your mobile device

Select Open local file

Add your project by clicking on the green and white + icon at the bottom left
Select Import project from folder and navigate to the QField folder on your
device

Now you can do field work!
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QField offline @

In QField: Synchronise back

Once done with your collection, it is time to synchronise the data with your
Desktop project:

e Re-open the project in QGIS (the one you saved with a regular Save As)

previously
e Copy the project folder from your mobile device to the Import folder on your

computer
e Direct to Plugin > QFieldSync > Synchronise from QField menu to

synchronise your changes from the QField project to the Desktop project
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Summary & key takeaways

QField bridges desktop GIS and field data collection

Proper QGIS project and layer configuration is essential for
success

Two deployment options: Cloud (internet required) or offline

Data synchronisation preserves all attributes and geometries



Sources

opengisch. (n.d.). QField for QGIS [GitHub repository]. Retrieved March 31, 2025, from
https://github.com/opengisch/QField
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https://github.com/opengisch/QField?utm_source=chatgpt.com
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