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In-situ sampling in QField



Learning objectives
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Configure QGIS projects for mobile field data collection.

Set up attribute forms with proper field types and constraints.

Deploy projects to QField using both cloud and offline methods.

Collect spatial data with photos and GPS coordinates in the field.

Synchronize field-collected data back to QGIS desktop.



What is QField?
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• Open-source mobile application for Android and iOS

• Enables editing QGIS projects on mobile devices

• Takes QGIS projects into the field for effective data collection

• Maintains QGIS styling and edit widgets

(opengisch n.d.)



QField workflow
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1.  Configure QGIS project (desktop)

2.  Set up data layers and attributes

3.  Deploy to QField

4.  Collect data in the field

5. Synchronise back to QGIS



Configuring the QGIS project
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● Folder structure:
○ Project Folder

■ Your QGIS project
■ “ExportQField”
■ “ImportQField”

● Save project without spaces in filename

Create the project



Configuring the QGIS project
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● Under the browser 
(top left)  you will 
find the dropdown 
XYZ Tiles

● Use the 
OpenStreetMap 
basemap

In QGIS: Basemap



Configuring the QGIS project
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● QGIS plugin: OSM Place Search
○ Allows you to browse through the different place features available in 

the OpenStreetMap data

● Under Plugins in the Menu toolbar, click Manage and Install Plugins
● In the search bar, type OSM Place Search and install the plugin
● A new window should appear in the side panel where you can enter your 

AOI

Area of Interest (AOI)



Creating the GeoPackage
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● A file-based database where you can store multiple layers, including 
points, lines, polygons, and raster data

● Datasets are saved in one file, instead of multiple (shapefiles)
● Ends in .gpkg

What is a GeoPackage?



Creating the GeoPackage
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Create a GeoPackage

● Select Layer > Create Layer > New 
Geopackage Layer:
○ For Database, click on (…) and 

select your project folder and give a 
suitable name

○ Choose a Table name
○ For Geometry type, select points
○ Select the desired Coordinate 

Reference System (CRS) by 
clicking on the Globe icon



Creating the GeoPackage
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Create a GeoPackage

● Select Layer > Create Layer > New 
Geopackage Layer:
○ For Database, click on (…) and 

select your project folder and give a 
suitable name

○ Choose a Table name
○ For Geometry type, select points
○ Select the desired Coordinate 

Reference System (CRS) by 
clicking on the Globe icon



Creating the GeoPackage
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Create a GeoPackage

● Under New Field add the following attribute columns:
○ lulc_class: Value Map widget with predefined options (Text)
○ Date: Auto-populated with now(), non-editable (Date and time)
○ Photo: Attachment widget with relative paths and document viewer 

(Text)
○ Latitude/Longitude: Auto-populated ($x, $y), non-editable (Decimal)

 



Creating the GeoPackage
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Create a GeoPackage

● Under New Field add the following attribute 
columns:
○ lulc_class: Value Map widget with 

predefined options (Text)
○ Date: Auto-populated with now(), 

non-editable (Date and time)
○ Photo: Attachment widget with relative 

paths and document viewer (Text)
○ Latitude/Longitude: Auto-populated 

($x, $y), non-editable (Decimal)



Creating the GeoPackage

EOCap4Africa – In-situ sampling in QField 13

Create a GeoPackage

● Under New Field add the following attribute 
columns:
○ lulc_class: Value Map widget with 

predefined options (Text)
○ Date: Auto-populated with now(), 

non-editable (Date and time)
○ Photo: Attachment widget with relative 

paths and document viewer (Text)
○ Latitude/Longitude: Auto-populated 

($x, $y), non-editable (Decimal)



Attribute configuration
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Edit file properties

1. Go the sample layer:  Layer 
Properties > Attribute Form

2. Select Drag and Drop Designer from 
the dropdown
○ Do not need to edit the fid field. 

QGIS creates this for every 
GeoPackage by default

3. Remove the fid field from the visible 
fields by pressing the -



Attribute configuration
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LULC_class

● Select lulc_class:
a. Change the Widget type from 

Text edit to Value Map
b. Enter the Value and Description 

for your lulc classes
c. Check the Not null button under 

the Constraint
d. Click Apply 



Attribute configuration
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Date

● Select date:
a. Make sure it has the Date/Time format under the Widget Type
b. Under General, uncheck Editable
c. Under Defaults, in the Default value type, use now()
d. Click Apply



Attribute configuration
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Photo

● Select photo:
a. In the Widget Type section, select 

Attachment
b. Check Relative paths and select 

Relative to Project Path
c. Check the ‘Use a hyperlink for 

document path” box
d. Select Image for the Type
e. Set Width and Height to 400px and 

300px
f. Click Apply



Attribute configuration
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Latitude and Longitude

● Edit latitude and longitude:
a. Under General, uncheck Editable.
b. In the Default value bar, type in $x for latitude and $y for longitude



QField synchronisation methods
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QField cloud

Two methods:

QField offline



QField synchronisation methods
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Cloud method Offline method

Automatic synchronisation Functions almost completely without 
wifi

Multiple users can work on the same 
project

Requires multiple manual steps (eg. 
USB transfer)

Easier setup More complex
Best for: most cases, teams, projects 
with many changes

Best for: extremely remote studies, 
sensitive data



QField cloud
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In QGIS: QField Sync Plugin

1. Direct to Plugins > Manage and 
Install Plugins > All

2. Search for QFieldSync and install it
3. In QGIS a new toolbar should appear
4. Start QField Sync
5. Login to QFieldCloud with your 

username and password. If you have 
no username you can directly 
register following the link



QField cloud
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In QGIS: QField Sync Plugin

6.  Click on Plugins > QFieldSync > 
QfieldCloud Projects Overview

7.  In the QFieldCloud Projects Overview 
window, click on the Create new Project



QField cloud
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In QGIS: QField Sync Plugin

6.  Click on Plugins > QFieldSync > 
QfieldCloud Projects Overview

7.  Click on the Create new Project

8.  Choose the recommended option 
and click Next

9.  You can enter a description and click 
on Create and QFieldSync will package 
your project for the cloud



QField cloud
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In QField: Synchronise in the app

1. On your mobile device open QField Application
2. Click on QFieldCloud Projects and sign in with the 

same credentials as before
3. Your project should already be available
4. Click on it and download the project



QField cloud
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In QField: Synchronise in the app

1. On your mobile device open QField Application
2. Click on QFieldCloud Projects and sign in with the 

same credentials as before
3. Your project should already be available
4. Click on it and download the project

Now you can do field work!



QField cloud
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In QField: Synchronise back

Open the Side Dashboard:

● Click on the blue cloud, the number 
indicates how many changes you have 
made)

● Choose to push the changes if you are 
happy with your field work



QField offline
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In QGIS: Prepare your project

Create an offline copy of your QGIS project as a new file by adding 
“_offline.qgs” into a new folder



QField offline
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In QGIS: Layer packaging

● Each layer needs a "Layer Action" to define how QFieldSync handles it

Available Action Types:

● Copy: Creates static copy, no change tracking (for reference data)
● Keep existing (copy if missing): Avoids re-packaging, best for frequent 

syncs
● Offline editing: Full tracking with changelog, enables synchronisation (for 

the field)
● Directly access data source: Real-time access (requires internet)
● Remove: Excludes layer from mobile project



QField offline
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In QGIS: Layer packaging

1. Add the Google Satellite basemap
2. Zoom into your area of interest usingOSM 

Place Search
3. Toolbox > Raster tools > Generate XYZ tiles 
4. Click Extent, select Draw on Map Canvas and 

draw AOI
5. Complete the dialog box as shown >
6. Save the file to the offline project folder created
7. Remove the Google Satellite basemap and add 

the saved MBTiles to the project



QField offline
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In QGIS: Package for QField

● Go to Plugins > QFieldSync 
> Preference

● Set the Default packaging 
import and export directory to 
the Import and Export 
Folders created on your local 
drive



QField offline
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In QGIS: Package for QField

● Click on the MBTiles in your layers > 
Properties > QField

● Change the Cable packing action to “Keep 
existent (Copy if missing)”

● Repeat this change for the lulc_samples 
layer and any additional layer you may 
have

● On the Toolbar, click on the Package for 
QField icon and confirm the packaged 
project directory

● Click Create to complete



QField offline
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In QGIS: Package for QField

● Click on the MBTiles in your layers > 
Properties > QField

● Change the Cable packing action to “Keep 
existent (Copy if missing)”

● Repeat this change for the lulc_samples 
layer and any additional layer you may 
have

● On the Toolbar, click on the Package for 
QField icon and confirm the packaged 
project directory

● Click Create to complete



QField offline
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In QField: Manually synchronise

● Copy the packaged folder into the qfield folder on your mobile device via 
USB, Mail, etc.

● Open QField App on your mobile device
● Select Open local file
● Add your project by clicking on the green and white + icon at the bottom left 
● Select Import project from folder and navigate to the QField folder on your 

device

Now you can do field work!



QField offline
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In QField: Synchronise back

Once done with your collection, it is time to synchronise the data with your 
Desktop project:

● Re-open the project in QGIS (the one you saved with a regular Save As) 
previously

● Copy the project folder from your mobile device to the Import folder on your 
computer

● Direct to Plugin > QFieldSync > Synchronise from QField menu to 
synchronise your changes from the QField project to the Desktop project
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QField bridges desktop GIS and field data collection

Proper QGIS project and layer configuration is essential for success

Two deployment options: Cloud (internet required) or offline

Data synchronisation preserves all attributes and geometries

Summary & key takeaways



Sources
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opengisch. (n.d.). QField for QGIS [GitHub repository]. Retrieved March 31, 2025, from 
https://github.com/opengisch/QField

https://github.com/opengisch/QField?utm_source=chatgpt.com
https://github.com/opengisch/QField?utm_source=chatgpt.com


Thank you for your attention!

Dr. Insa Otte, Hanna Schulten 
(on behalf of the EOCap4Africa Team) 
and colleagues

insa.otte@uni-wuerzburg.de

37


